Undefined property: CWebApplication::$db

Решаем проблемы установки на различные окружения и хостинги

Модератор: core team

duke706116
Новенький
Сообщения: 2
Зарегистрирован: Сб май 16, 2015 8:32 am

Undefined property: CWebApplication::$db

Сообщение duke706116 » Сб май 16, 2015 8:40 am

Сразу при запуске выдает ошибку:
Notice: Undefined property: CWebApplication::$db in /usr/local/www/yii/yupe-project/protected/modules/yupe/components/WebModule.php on line 1012
Fatal error: Call to a member function cache() on a non-object in /usr/local/www/yii/yupe-project/protected/modules/yupe/components/WebModule.php on line 1013

Ставил через composer.
Система FreeBSD 10.1 + nginx 1.8.0 + php 5.4.4 (php-fpm через сокет) + mysql 5.6.24.
Конфигурацию нжинкса брал в том числе из папки yupe-project/read.me - результат одинаков.
В порядке маразма попробовал даже руками базу создать и прописать ее в protected/config/db.php.

Аватара пользователя
xoma
Администратор
Сообщения: 1924
Зарегистрирован: Ср авг 22, 2012 8:54 am
Контактная информация:

Re: Undefined property: CWebApplication::$db

Сообщение xoma » Вс май 17, 2015 9:53 am

Удалите файл protected/config/db.php его не должно быть на момент установки, если он есть - это какая-то бага.
Расскажите о причинах, если решите проблему.
http://yupe.ru/subscribe - интересное от команды "Юпи!"

duke706116
Новенький
Сообщения: 2
Зарегистрирован: Сб май 16, 2015 8:32 am

Re: Undefined property: CWebApplication::$db

Сообщение duke706116 » Ср май 20, 2015 6:47 am

Спасибо, получилось.

sergmol
Новенький
Сообщения: 2
Зарегистрирован: Чт июл 09, 2015 3:27 pm

Re: Undefined property: CWebApplication::$db

Сообщение sergmol » Чт июл 09, 2015 7:31 pm

на винде не спасает ... оранжевая таблица уже примелькалась ...

Аватара пользователя
sabian
Ниндзя
Сообщения: 334
Зарегистрирован: Ср фев 18, 2015 8:34 pm
Откуда: Воронежская область
Контактная информация:

Re: Undefined property: CWebApplication::$db

Сообщение sabian » Чт июл 09, 2015 9:17 pm

sergmol писал(а):на винде не спасает ... оранжевая таблица уже примелькалась ...

Опишите, пожалуйста, вашу конфигурацию и как устанавливаете, чтобы можно было попытаться повторить проблему.

brainfcker
Новенький
Сообщения: 1
Зарегистрирован: Вт июн 06, 2017 11:31 pm

Re: Undefined property: CWebApplication::$db

Сообщение brainfcker » Вт июн 06, 2017 11:35 pm

Столкнулся с такой же ошибкой в другом месте, но при переносе уже рабочего сайта на nic.ru. При этом на timeweb всё без проблем

Код: Выделить всё

Notice: Undefined property: CWebApplication::$db in /home/sitename/sitename55.ru/docs/protected/modules/yupe/components/WebModule.php on line 1031

Notice: Undefined property: CWebApplication::$db in /home/sitename/sitename55.ru/docs/protected/modules/yupe/components/WebModule.php on line 1031

Fatal error: Uncaught Error: Call to a member function createCommand() on null in /home/sitename/sitename55.ru/docs/protected/modules/yupe/components/WebModule.php:1033
Stack trace: #0 /home/sitename/sitename55.ru/docs/protected/modules/yupe/components/WebModule.php(1014): yupe\components\WebModule->getSettings()
#1 /home/sitename/sitename55.ru/docs/vendor/yiisoft/yii/framework/base/CModule.php(90): yupe\components\WebModule->init()
#2 /home/sitename/sitename55.ru/docs/vendor/yiisoft/yii/framework/YiiBase.php(206): CModule->__construct('yupe', NULL, Array)
#3 /home/sitename/sitename55.ru/docs/vendor/yiisoft/yii/framework/base/CModule.php(282): YiiBase::createComponent(Array, 'yupe', NULL, Array)
#4 /home/sitename/sitename55.ru/docs/protected/modules/yupe/components/urlManager/LangUrlManager.php(63): CModule->getModule('yupe')
#5 /home/sitename/sitename55.ru/docs/vendor/yiisoft/yii/framework/base/CModule.php(394): yupe\components\urlManager\LangUrlManager->init()
#6 /home/sitename/sitename55.ru/docs/vendor/yiisoft/yii/fram in /home/sitename/sitename55.ru/docs/protected/modules/yupe/components/WebModule.php on line 1033


Куда копать?

Аватара пользователя
xoma
Администратор
Сообщения: 1924
Зарегистрирован: Ср авг 22, 2012 8:54 am
Контактная информация:

Re: Undefined property: CWebApplication::$db

Сообщение xoma » Ср июн 07, 2017 10:27 am

Попробуйте очистить кеш данных и кеш настроек.
http://yupe.ru/subscribe - интересное от команды "Юпи!"


Вернуться в «Установка и настройка»

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 1 гость