Помогите, не могу установить.

Решаем проблемы установки на различные окружения и хостинги

Модератор: core team

Аватара пользователя
absorberex
Новенький
Сообщения: 6
Зарегистрирован: Пт июн 26, 2015 12:26 am
Контактная информация:

Помогите, не могу установить.

Сообщение absorberex » Пт июн 26, 2015 12:31 am

Привет всем.
Раньше с Yii никогда не имел дело, но наслышан о нем.
Решил попробовать вашу CMS, но возникли проблемы с установкой, которые я не могу решить вот уже целый вечер.

Скачал полный пак yupe.
Ставлю на OpenServer последней версии. (система Win 7 x64)
При запуске сайта следующая ошибка:
Fatal error: Uncaught exception 'UnexpectedValueException' with message 'GlobIterator::__construct(): open_basedir restriction in effect. File(glob://D:\OpenServer\domains\yupe\protected\config/..modules*.php) is not within the allowed path(s): (d:/openserver/domains;d:/openserver/userdata/temp;d:/openserver/modules/system/html/openserver;d:/openserver/modules/php/PHP-5.5)' in D:\OpenServer\domains\yupe\protected\modules\yupe\components\ConfigManager.php:216 Stack trace: #0 D:\OpenServer\domains\yupe\protected\modules\yupe\components\ConfigManager.php(216): GlobIterator->__construct('D:\\OpenServer\\d...') #1 D:\OpenServer\domains\yupe\protected\modules\yupe\components\ConfigManager.php(151): yupe\components\ConfigManager->prepareSettings() #2 D:\OpenServer\domains\yupe\protected\modules\yupe\components\ConfigManager.php(137): yupe\components\ConfigManager->getSettings() #3 D:\OpenServer\domains\yupe\public\index.php(35): yupe\components\ConfigManager->merge(Array) #4 {main} thrown in D:\OpenServer\domains\yupe\protected\modules\yupe\components\ConfigManager.php on line 216

Прежде искал ответ как в гугле/яндексе, так и тут на форуме.
Перечитал документацию несколько раз.
Объясните пожалуйста, в чем проблема!

Аватара пользователя
Dark_Cs
core team
Сообщения: 121
Зарегистрирован: Пт окт 25, 2013 2:34 pm

Re: Помогите, не могу установить.

Сообщение Dark_Cs » Пт июн 26, 2015 10:04 pm

вот тут пытается система узнать есть ли модуль, чей конфиг лежит в папке с конфигами, но у него не получается https://github.com/yupe/yupe/blob/maste ... r.php#L216

если поискать по "open_basedir restriction in effect.", то можно увидеть, что это происходит из-за того, что нет прав на чтение вне домашней папки, хотя на openserver с настройками по умолчанию с таким никогда не сталкивался

kostya
Новенький
Сообщения: 4
Зарегистрирован: Вт янв 19, 2016 8:01 pm

Re: Помогите, не могу установить.

Сообщение kostya » Вт янв 19, 2016 8:15 pm

Всем доброго времени!
Решил установить Юпи на локалку, но без результата!
Скачал версию 0.9.9 со страницы http://yupe-project.ru/download, установил Endels (php 5.4.41), архив Юпи распаковал в test2.kz/www/ (пробовал разные пути) но без результат, установка не начинается!
Делал все как написано тут http://yupe.ru/docs/yupe/install.html начиная с Загрузка полного архива (включая все зависимости), правда тут написано: переходим на страницу загрузки http://yupe.ru/download и скачиваем последнюю версию но по этой ссылке нет ничего!
В общем так и не понял как установить Юпи, а именно нужен интернет магазин!
Может обьясните по подробнее как это реализовать!?

Аватара пользователя
sabian
Ниндзя
Сообщения: 351
Зарегистрирован: Ср фев 18, 2015 8:34 pm
Откуда: Воронежская область
Контактная информация:

Re: Помогите, не могу установить.

Сообщение sabian » Вт янв 19, 2016 9:52 pm

Какие-либо ошибки отображаются на экране или в логах?
Правильно-ли вы настроили свой сервер?

Новая документация по установке Юпи http://guides-v1.yupe-project.ru/install/

kostya
Новенький
Сообщения: 4
Зарегистрирован: Вт янв 19, 2016 8:01 pm

Re: Помогите, не могу установить.

Сообщение kostya » Ср янв 20, 2016 7:52 am


kostya
Новенький
Сообщения: 4
Зарегистрирован: Вт янв 19, 2016 8:01 pm

Re: Помогите, не могу установить.

Сообщение kostya » Ср янв 20, 2016 9:08 am

Ребята, не могу найти как установить скачанный новый модуль!?
Да и вообще как устанавливать дополнительные сервисы, модули?

Аватара пользователя
sabian
Ниндзя
Сообщения: 351
Зарегистрирован: Ср фев 18, 2015 8:34 pm
Откуда: Воронежская область
Контактная информация:

Re: Помогите, не могу установить.

Сообщение sabian » Ср янв 20, 2016 11:51 am

Копируете в папку protected/modules, затем заходите в панели управления в раздел Юпи - Модули. Там будет вкладка "Не установлен". Находите нужный и жмете установить.

kostya
Новенький
Сообщения: 4
Зарегистрирован: Вт янв 19, 2016 8:01 pm

Re: Помогите, не могу установить.

Сообщение kostya » Ср янв 20, 2016 12:41 pm



Вернуться в «Установка и настройка»

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 2 гостя